Friday, 24 July 2015

Errors And Fixes While booting


When I start the centos 6.2 system centos6 logo stucked it didn't give the login prompt
So, I restart the system by CTRL+ALT+DELETE and i pressed the ESC key when circle had come
to see the errors.
The errors are:
  • unexpectedly disconnected from boot status daemon
  • init: prefdm respawning too fast,stopped
In my system may be These errors are because httpd remove/update.

Before this I did following:
I removed httpd by #yum remove httpd*
after that I installed httpd-2.4.10 source file by following some steps.
After i reboot the system i got the above errors.

There are two ways to fix these errors:
  • by rescue installed system from centos 6.2 dvd
  • by upgrade an existing system from centos 6.5 dvd
Rescue installed system:
  • Insert centos 6.2 dvd
  • press F10 key
  • select cd/dvd sta
  • select rescue installed system
  • Language English OK
  • US OK
  • Drive Local cd/dvd OK
  • Enable network interface OK
  • Configure network IPv4 settings manually by giving IP address,Gateway and Nameserver
  • after that press OK until you get command line prompt like bash4.1$
  • $chroot /mnt/sysimage
  • #yum remove httpd*
  • you have to install httpd-2.2.15-29.el6.centos.x86_64
  • Download following rpm packages in another linux system
  • In that goto downloads copy the above three files to one folder and copy that folder to Desktop
  • compress the folder to .zip(httpd.zip)
  • now open terminal
  • #cd /root/Desktop
  • ftp 192.168.1.22 /*your system ip address*/
  • ftp>cd /root
  • ftp>bin
  • ftp>hash
  • ftp>prompt
  • ftp>mput httpd.zip
  • ftp>bye
  • now from your system #cd /root
  • #unzip httpd.zip
  • #rpm -ivh httpd-2.2.15-29.el6.centos.x86_64.rpm
  • #rpm -ivh httpd-devel-2.2.15-29.el6.centos.x86_64.rpm
  • #rpm -ivh httpd-tools-2.2.15-29.el6.centos.x86_64.rpm
  • #sync
  • #exit
  • #reboot
hence problem solved

No comments:

Post a Comment